Changes to Webservices Search

jperreault's Avatar

jperreault

12 Jun, 2013 08:50 PM

Hi, we are upgrading from version 6.8 to version 7.0.x and maybe to 7.2.x

I am having a problem with our existing integration after the upgrade. Most things still work, but specifically I have a problem searching using assetOperationHandler.search. I can see from the release notes below, that there have been a lot of changes to the SearchInformation class, but I don't see any extra parameters are required.
http://hannonhill.com/kb/Web-Services/Web%20Services%20Changelog/in...

My application tries to search for a page, where the UserMetadata:Description field contains a number ( see the attached screenshot for an example of what the User metadata page looks like ).

Below is my function which used to find the page, so that I could update it. Now it seems to return null in the search matches

public Identifier[] findIdentifiers(Person person) throws RemoteException {
        Asset asset = null;
        SearchInformation info = new SearchInformation();

        info.setMatchType(SearchMatchType.value1); // value1=match all / value2 = match any);

        // search only pages
        info.setSearchPages(true);
        info.setSearchBlocks(false);
        info.setSearchFormats(false);
        info.setSearchTemplates(false);

        // search for PIDM, something like this : info.setAssetMetadata("90233083"); 
        info.setAssetMetadata(person.getPidm());

        SearchResult result;
        result = assetOperationHandler.search(authentication, info);
        SearchMatches sm = result.getMatches();

        return sm.getMatch();
    }

Is there something else that I am might be missing ?

Thanks for your help.

  1. Support Staff 1 Posted by Tim on 19 Jun, 2013 09:25 PM

    Tim's Avatar

    Hi,

    Sorry for the delay. I haven't had a chance to set this up locally yet, but I was able to check with one of my developers to see if he could provide some quick insight. The first thing you should do is verify that you are getting results through the Advanced Search in the Cascade Server interface. If you aren't, try rebuilding your search indexes and see if that corrects the problem.

    Also, this portion of your code:

    result = assetOperationHandler.search(authentication, info);
    SearchMatches sm = result.getMatches();
    
    may be invalid. For us, the following worked:
    result = assetOperationHandler.search(authentication, info);
    Identifier[] matches = result.getMatches();
    
    Let me know if this info helps at all!
  2. 2 Posted by jperreault on 25 Jun, 2013 11:00 PM

    jperreault's Avatar

    Hi Tim,

    I started going through the release notes and I found a bug fix in version 7.0.7 which sounded like a possibility:
    https://hannonhill.jira.com/browse/CSI-497

    I upgraded our test instance to version 7.2.2 and started testing again. This time the search worked as expected.

    Thanks for your help.

  3. Support Staff 3 Posted by Tim on 25 Jun, 2013 11:12 PM

    Tim's Avatar

    Awesome. Glad to hear it's working now. Thanks for the update,!

  4. Tim closed this discussion on 25 Jun, 2013 11:12 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac