Blocks inside Pages

ddent's Avatar

ddent

06 Feb, 2013 04:06 PM

I have a Data Definition that uses a page chooser to include a page for the purposes of "cloning" that page between sites.

These pages use an XHTML/DD Block asset chooser to add reusable content as well.

If I "clone" a page with a block in it the content of the block isn't rendered.

Any suggestions?

  1. 1 Posted by Ryan Griffith on 06 Feb, 2013 08:43 PM

    Ryan Griffith's Avatar

    Hi,

    It sounds like you may want to try increasing the render-content-depth option for your Page chooser.

    Another place you may want to look is the Depth of Index option for the calling page Index Block being used on the Page that contains the Page chooser. There may be a possibility that this Index Block isn't set to go deep enough.

    Please let me know if you have any questions.

    Thanks

  2. 2 Posted by ddent on 07 Feb, 2013 02:22 PM

    ddent's Avatar

    The render content depth is set to 9, so that isn't really a factor. The second nested block is only 5 layers in.

    The Depth of index is 0 (which is supposed to be unlimited).

    All I can see is the path for the block, there is no block at all.

  3. 3 Posted by Ryan Griffith on 07 Feb, 2013 03:21 PM

    Ryan Griffith's Avatar

    Hi,

    Thank you for the additional information.

    Just a few more questions to see if we can narrow things down a bit:

    • What is the render-content-depth option for the Block chooser on your included page? If this is also not high enough, you will not see the contents of the Block within the contents of the chosen Page.
    • Assuming you have a "calling page" Index Block (see "How to I create a 'current page' index block" FAQ) applied to your first page with the Page chooser, can you attach a screenshot of the settings for this Block?

    Please let me know if you have any questions.

    Thanks

  4. 4 Posted by ddent on 08 Feb, 2013 02:35 PM

    ddent's Avatar

    That was it!

    The **render-content-depth** option for the *Block* chooser was set to only
    2 even though the *Page* chooser was set to 15. When I upped the Block
    chooser to 9 the content appeared.

    The 2 value worked fine on the original page, but not once it was cloned on
    the second page.

    Dave

  5. 5 Posted by Ryan Griffith on 08 Feb, 2013 03:03 PM

    Ryan Griffith's Avatar

    Thank you for the follow up, Dave. Glad to hear that did the trick.

    I believe you encountered this known defect in which values other than 1 and unlimited in render-content-depth are not intuitive during the rendering process, especially when dealing with nested choosers. Feel free to track the progress of this issue to see if it has been resolved in a future release of Cascade.

    I'm going to go ahead and close this discussion, please feel free to comment or reply to re-open if you have any additional questions.

    Thanks

  6. Ryan Griffith closed this discussion on 08 Feb, 2013 03:03 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac