Upgrade Problem

Mark St. Laurent's Avatar

Mark St. Laurent

09 Sep, 2015 09:31 PM

So we are upgrading our 7.0.7 installation to 7.14.2. At the same time we are moving our database from SQL Server 2005 to a clustered SQL Server 2012 installation. We completed the move in our test environment, the server boots up and runs and we can log in without any problems. But once we are logged in and attempt to make a test edit, we receive the following error:

An error occurred during editing: could not delete: [com.hannonhill.cascade.model.dom.Page#b39c9affac100321331d20d8ed02477c]; SQL [delete from cxml_foldercontent where id=?]; nested exception is org.hibernate.exception.SQLGrammarException: could not delete: [com.hannonhill.cascade.model.dom.Page#b39c9affac100321331d20d8ed02477c]

Any insight?

Thanks,
Mark

  1. Support Staff 1 Posted by Tim on 09 Sep, 2015 10:32 PM

    Tim's Avatar

    Hi Mark,

    When you have a moment, can you please attach your latest cascade.log file? It should have more context for us with respect to the error you are seeing.

    Thanks!

  2. Support Staff 2 Posted by Tim on 09 Sep, 2015 10:32 PM

    Tim's Avatar

    The log files can be found on the application server in the Cascade installation directory under tomcat/logs.

  3. 3 Posted by Mark St. Lauren... on 09 Sep, 2015 10:35 PM

    Mark St. Laurent's Avatar

    Here you go.

  4. Support Staff 4 Posted by Tim on 09 Sep, 2015 11:03 PM

    Tim's Avatar

    Thanks, Mark. There are a couple of issues I'm seeing in the log file:

    Database deadlock Immediately after startup, it looks like some deadlock was encountered. Some amount of deadlock was expected and the application will simply retry the transaction, but I want to make sure that you all have properly configured your snapshot isolation. When you have a moment, can you verify that snapshot isolation is indeed enabled for your Cascade Server database? To do so, run this query:

    SELECT is_read_committed_snapshot_on FROM sys.databases WHERE name='{databaseName}';
    
    (replace {databaseName} with the name of your Cascade database)

    It should return a 1.

    Invalid object names The latest errors in the log file are related to tables in the database:

    Caused by: java.sql.SQLException: Invalid object name 'cxml_assetstats'.
    
    This makes me think that the database user specified in your tomcat/conf/context.xml file may not permissions to see the table in the Cascade database. Can you try logging into SQL Server Management Studio using these same credentials and then see if you're able to view any of the tables in there? Also, was anything changed with respect to the database user that you initially had been connecting with throughout the day today? The reason I ask is because it looks like the application was able to connect and upgrade database tables a little after noon, but then began running into this problem about 15 minutes or so later.

    After you've verified that the database user has full privileges to all tables within the Cascade database, I'd like for you to do the following:

    • Stop any running Cascade processes (if there are any)
    • Delete everything in tomcat/logs
    • Delete the tomcat/work directory
    • Start Cascade again

    If there are still problems accessing the application, zip up everything in tomcat/logs and attach that archive here.

    Thanks!

  5. 5 Posted by Mark on 11 Sep, 2015 07:58 PM

    Mark 's Avatar

    Hi, Tim,

    We tried the items you suggested without any results. However, what we did discover is that the user who was testing the environment and getting the error message was using a non-LDAP account (a native Cascade account). When we tested the environment with a LDAP account, it worked fine. Since that was the only user using a native account, we simply created a new LDAP account for that user, and it is now working fine. Not sure what the actual problem with that account is, but the workaround is fine. You can close this out.

    Thanks,
    Mark

  6. Support Staff 6 Posted by Tim on 11 Sep, 2015 08:03 PM

    Tim's Avatar

    Hi Mark,

    Thanks for the update. When you have a moment, can you attach your latest cascade.log file here? I realize the issue is no longer occurring for you (which is great), but I'm still curious as to what may have happened since the way users actually authenticate with Cascade isn't connected at all to how it the database user is authorized when starting the application.

    Thanks!

  7. Tim closed this discussion on 22 Sep, 2015 04:24 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac