Update Error on Cascade startup

jsmohrfeld's Avatar

jsmohrfeld

06 Apr, 2015 07:49 PM

I have been attempting to perform a ROOT.war update to a development version of our Cascade Server installation. We are currently going from a 7.x version to the newest version. I have followed all the steps in the upgrade guide however I have been running into an error where the java process runs into a null pointer exception and repeatedly outputs that to the cascade.log in investigating on my own I ran across a discussion which brought up looking in the localhost.log and I have included them both. Any help that could be offered would be greatly appreciated. Thank you.

Jeremy

  1. Support Staff 1 Posted by Tim on 06 Apr, 2015 08:04 PM

    Tim's Avatar

    Hi Jeremy,

    The underlying problem is this error message:

    Caused By: Error executing SQL CREATE INDEX IDX_STALEFILTER_USER ON cxml_stalefilter(userId):
              Caused By: Duplicate key name 'IDX_STALEFILTER_USER'
    
    which basically indicates that the application is attempting to create an index on the database but that index is already there.

    A few questions for you:

    • Can you tell me what time you first attempted the upgrade (by starting Cascade 7.12.5 against your existing database)?
    • What version are you upgrading from?

    At this point I would recommend trying the following:

    • Stop the Cascade Server process (if it's still running)
    • Execute the following SQL query against your database:
      DROP INDEX  IDX_STALEFILTER_USER ON cxml_stalefilter
      
    • Start Cascade Server and let it run until you get to a login page

    If you don't see a login page after about 5 minutes, leave the process running and attach your most recent cascade.log files here.

    Thanks!

  2. 2 Posted by jsmohrfeld on 06 Apr, 2015 09:11 PM

    jsmohrfeld's Avatar

    Tim:

    I did as you suggested and dropped the index. It dropped successfully but is still having the same issue occurring. I checked the log and it does still generate that error however I am afraid that the cascade.log will be of little use to you as it is still just generating "ERROR [MemoryQueueSearchJobScheduler] An error occurred while consuming from the lucene event queue: java.lang.NullPointerException"

    Please let me know if I can provide or do anything else. Thank you.

    Jeremy

  3. Support Staff 3 Posted by Tim on 06 Apr, 2015 10:47 PM

    Tim's Avatar

    Hi Jeremy,

    Yea, the errors:

    ERROR [MemoryQueueSearchJobScheduler] An error occurred while consuming from the lucene event queue: java.lang.NullPointerException
    
    tend to spam the log file any time there is some other issue preventing the app from starting.

    Which version are you upgrading from? Regardless, at this point I'd like for you to do the following:

    • Stop the Cascade Server process and verify that there are no running java or tomcat processes on the machine (if there are, kill them)
    • Delete the folder tomcat/logs
    • Restore your database using a backup from prior to the upgrade attempt
    • Execute the following SQL queries and attach the results here:
      > select * from DATABASECHANGELOG;
      
      > show tables;
      
    • Start Cascade Server 7.12.5 against your database, then let the process run for 15 minutes

    If you can't reach a login screen after waiting 15 minutes, leave it running and then zip up and attach your latest cascade.log file and we'll see if you're getting the same error.

    Thanks!

  4. Support Staff 4 Posted by Tim on 17 Apr, 2015 06:52 PM

    Tim's Avatar

    Hi Jeremy,

    Just checking in here to see if you need any more help. Let us know!

    Thanks

  5. Tim closed this discussion on 04 May, 2015 06:42 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac