Windows Installation Service Error

jscott02's Avatar

jscott02

01 Jun, 2012 03:17 PM

Hey, I am trying to get an installation of Cascade running on a new Windows 2008 VM server and for some reason its not creating the service in windows after the installation. I am getting the error, "The specified service does not exist as an installed service. Unable to open the service 'cascade'," am I am not sure what to do.

  1. 1 Posted by Bradley Wagner on 01 Jun, 2012 03:30 PM

    Bradley Wagner's Avatar
    • Which version of Cascade are you attempting to install?
    • Are you at attempting to use a 32-bit or 64-bit version of Java?
    • Have you tried uninstalling and re-installing the service using our installation guide
  2. 2 Posted by jscott02 on 01 Jun, 2012 03:38 PM

    jscott02's Avatar

    Thanks for the reply.
    I am trying to install 6.10.9, and I have installed the 64 bit version of Java.

    I have tried to uninstall and re-install using the guide, but once I get to step 5 (Double-click the file cascadew.exe) I get the error I explained in the initial post.

  3. 3 Posted by Bradley Wagner on 01 Jun, 2012 05:04 PM

    Bradley Wagner's Avatar

    Do you remember if you checked "Start Cascade Server Automatically on boot" when installing Cascade 6.10.9? Is looks like the Cascade service was not installed during the 6.10.9 installation and thus can't be configured.

    To confim, let's:

    1. Open a command prompt and navigate to the tomcat\bin directory inside of your Cascade directory
    2. Type: service install cascade
    3. Then follow steps 3-5 again from the installation guide
  4. 4 Posted by jscott02 on 01 Jun, 2012 05:10 PM

    jscott02's Avatar

    I made sure I checked the box. I attached what I get when I run the commands.

  5. 5 Posted by Bradley Wagner on 01 Jun, 2012 05:30 PM

    Bradley Wagner's Avatar

    Thanks. We're looking into what could be causing that particular error.

  6. 6 Posted by Bradley Wagner on 01 Jun, 2012 06:56 PM

    Bradley Wagner's Avatar

    Are you attempting to install Cascade for the first time on this machine or did you have Cascade running as a service before? We think this could be related to the user you're using to install Cascade not having the necessary permissions to install a Windows Service. Can you verify your user's permissions and roles and try the above procedure as an Administrator if your user is not one already?

  7. 7 Posted by jscott02 on 01 Jun, 2012 07:11 PM

    jscott02's Avatar

    This is the first time on this machine but I am using an existing clone db from production. I am definitely an admin on the VM but I will keep trying and respond again next week if I still can't get it to work.

  8. 8 Posted by jscott02 on 05 Jun, 2012 02:03 PM

    jscott02's Avatar

    Brad, I have confirm that I am an admin of the system and still now able to install the service. Do you all have any direction on how to install the service manually?

  9. Support Staff 9 Posted by Tim on 05 Jun, 2012 02:15 PM

    Tim's Avatar

    Hi Joel,

    When you open the command prompt, are you doing so using the 'Run as Administrator' option? If not, please try this and let me know if that works.

    If the installation of the service fails again, can you tell me if you attempted to follow the instructions for using the 64-bit Windows service (the 32-bit Windows service is the default)? I want to make sure that there isn't some sort of problem occurring due to a mismatch between 32-bit and 64-bit files in the Tomcat directory.

    Thanks

  10. 10 Posted by jscott02 on 05 Jun, 2012 03:02 PM

    jscott02's Avatar

    Thanks that works, I am following the 64 bit instructions, the services now gets installed. However, now another issue, I am now getting a 404 page after I stated cascade.

    HTTP Status 404 -

    type Status report

    message

    description The requested resource () is not available.

    Apache Tomcat/6.0.32

  11. Support Staff 11 Posted by Tim on 05 Jun, 2012 03:08 PM

    Tim's Avatar

    OK, that sounds like a different issue. Can you attach your most recent tomcat\logs\cascade.log file to this discussion? It should give me an idea of where things are going wrong.

    Thanks

  12. 12 Posted by jscott02 on 05 Jun, 2012 03:11 PM

    jscott02's Avatar

    This comment was split into a new discussion: Problem starting Cascade Server

    Here is the log

  13. Support Staff 13 Posted by Tim on 05 Jun, 2012 03:15 PM

    Tim's Avatar

    Thanks, Joel. I'm splitting this discussion into a new one since the first issue regarding the service has been resolved.

  14. Tim closed this discussion on 05 Jun, 2012 03:15 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac