Warn at startup after upgrade from 6.10.9 to 7.14.2

Benoît's Avatar

Benoît

12 Feb, 2015 12:48 PM

Dear all,

After upgrading from 6.10.9 to 7.14.2, I still have the following WARN during each startup(see complete stacktrage attached) :

 [StartupTasks] *** Running startup task: OptimizeStructuredDataStartupTask
2015-02-12 13:41:55,033 INFO  [OptimizeDatabaseServiceImpl] Clearing orphaned assets...
2015-02-12 13:41:55,033 INFO  [OptimizeDatabaseServiceImpl] Clearing orphaned Data Definition nodes...
2015-02-12 13:41:55,048 INFO  [OptimizeDatabaseServiceImpl] Deleted 0 orhpaned Data Definition nodes
2015-02-12 13:41:55,049 INFO  [OptimizeDatabaseServiceImpl] Finished clearing 0 orphaned Data Definition node record(s)
2015-02-12 13:41:55,049 INFO  [OptimizeDatabaseServiceImpl] Fixing Structured Data with missing owner entity property
2015-02-12 13:41:55,053 INFO  [OptimizeDatabaseServiceImpl] Found 23 broken Structured Data nodes
2015-02-12 13:41:55,407 WARN  [StartupTasks] Startup task: OptimizeStructuredDataStartupTask failed to execute successfully but will not prevent login.  Exception is as follows:
com.hannonhill.cascade.model.dao.exception.DomainObjectValidationException: A domain object failed validation
1 total errors...
Error detail: 
  Object name: com.hannonhill.cascade.model.dom.StructuredData@606e8697[type=structureddata,id=d487a5a3c0a8644201aa09332cda8d82]
  Global errors:
  Field errors:
    field: name
      field.required.com.hannonhill.cascade.model.dom.StructuredData@606e8697[type=structureddata,id=d487a5a3c0a8644201aa09332cda8d82].name
      field.required.name
      field.required.java.lang.String
      field.required

Could you please help us solving this problem, what should be the steps ? Is it problematic for our instance ?

Thanks a lot for your help,

Best regards,

Benoît

  1. Support Staff 1 Posted by Tim on 12 Feb, 2015 02:19 PM

    Tim's Avatar

    Hi Benoît,

    I think a good starting point would be for us to have a look at the record in the database for the item that appears to be causing issues. When you have a moment, can you please execute the following SQL queries and attach the results from each one as a file?

    select * from cxml_structureddata where id = 'd487a5a3c0a8644201aa09332cda8d82';
    
    select * from cxml_structureddata where name is null;
    

    Thanks!

  2. 2 Posted by Benoît on 12 Feb, 2015 04:07 PM

    Benoît's Avatar

    Hi Tim,

    Thanks for your reply,
    I attached the result of the two sql querie's results in the response.

    Should I eventually delete the row matchind the id ?

    Thanks,

    Benoît

  3. Support Staff 3 Posted by Tim on 12 Feb, 2015 04:24 PM

    Tim's Avatar

    Thanks for the information, Benoît. Let me look over these results with my developers and I'll let you know what the next course of action should be.

  4. Support Staff 4 Posted by Tim on 12 Feb, 2015 07:56 PM

    Tim's Avatar

    Benoît,

    When you have a moment, please do the following:

    • Click System Menu -> Utilities -> Database Tools -> Optimize Database
    • On the next screen, check ONLY the option Remove orphaned records (leave the rest unchecked)
    • Click Submit

    Once that completes, let me know if you're still seeing that warning message on startup.

    Thanks!

  5. 5 Posted by Benoît on 13 Feb, 2015 04:36 PM

    Benoît's Avatar

    Thanks for your reply !

    I did the Optimization like you described. (See logs attached). But we still have the same WARN at startup. Does the Repair Structured Data checkbox would help ?

    Many thanks for your support,

    Best regards,

    Benoît

  6. Support Staff 6 Posted by Tim on 13 Feb, 2015 08:43 PM

    Tim's Avatar

    You can try running that option as well if you'd like. It may do the trick, but I would have thought that the 'remove orphaned records' option would work (since that's essentially what these records are in your database).

    Let me know if that option resolves the issue. If not, we can look into providing you with queries to safely remove them from your database.

    Thanks!

  7. 7 Posted by Benoît on 16 Feb, 2015 10:20 AM

    Benoît's Avatar

    Hello,

    I tried the "Repair Structured Data" and it raises directly the error in the logs (see attached).

    That would be great if you could provide me a safe way to remove the entry causing the trouble.

    Many thanks,

    Benoît

  8. Support Staff 8 Posted by Tim on 16 Feb, 2015 06:52 PM

    Tim's Avatar

    Benoît,

    When you have a moment, please try the following:

    • Create a backup of your database (just to be safe!)
    • Execute the following SQL query:
      update cxml_structureddata set name='temp' where name is null;
      
    • Restart Cascade Server and check for the warning messages

    Let me know if that does the trick.

    Thanks!

  9. 9 Posted by Benoît on 17 Feb, 2015 09:32 AM

    Benoît's Avatar

    Hi Tim,

    Thanks for the query, it took 7 minutes to be executed and updated 10 records.

    The WARN disappeared from the logs.

    Many Thanks,

    Benoît

  10. Support Staff 10 Posted by Tim on 17 Feb, 2015 01:17 PM

    Tim's Avatar

    Perfect. Glad to hear that did the trick, Benoît. Take care!

  11. Tim closed this discussion on 17 Feb, 2015 01:17 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac