6.10.9 upgrade and install error - (Error configuring application listener of class )

gotankersley's Avatar

gotankersley

17 Feb, 2012 06:02 PM

We are trying to upgrade / install Cascade 6.10.9 on Windows 2008 / mysql. Unfortunately, I'm having some troubles with the install. There doesn't seem to be a cascade.log file generated - the only thing that seems to point to an error is in the localhost file. Any clues would be appreciated!

  1. 1 Posted by chaoaj on 17 Feb, 2012 07:21 PM

    chaoaj's Avatar

    Not sure if this will be similar to your experience, but I just had osme
    issues with installing on Win2K8 MySQL and it was due to a runaway AJP
    process on port 8009 and I had to kill that process using these commands
    before the new start of Cascade Service would happen correctly.

    1)Find port conflicts if any with Cascade ports in tomcat/conf/server.xml
    file
    AJP 8009 default port is often an issue or shutdown port of 8005.
    Run from command line: netstat -ano
    and find process id
    2)then do a taklist by pid lookup where 1234 is the process # from step 1
    tasklist /svc /FI "PID eq 1234"
    3)Then kill task:
    ³taskkill /f /im [process name] /t² syntax or the ³taskkill /f /pid
    [process id] /t²

    Regards,
    @lvin

    ------------------------
    Alvin Chao ­ IT Web
    JMU - MSC 5734 - Massnutten Hall 293
    Harrisonburg, VA 22807
    540-568-6206
    [email blocked]
    http://educ.jmu.edu/~chaoaj

  2. 2 Posted by Joel on 17 Feb, 2012 07:25 PM

    Joel's Avatar

    Ivin could very well be correct in his assessment, but I would also check to see if the ROOT.war file (found within /CascadeServer/tomcat/webapps) has exploded into it's ROOT directory (/CascadeServer/tomcat/webapps/ROOT/). If it hasn't, please attach all log files found within your /tomcat/log directory and let me know what the permissions are for the webapps (and it's children) directory.

    Thanks!

  3. 3 Posted by gotankersley on 17 Feb, 2012 09:08 PM

    gotankersley's Avatar

    Thanks for the suggestion Chaoaj, but I think it must be a different issue - 'cause on running the netstat -ano command, I couldn't find any processes using either port 8005, or 8009...

    It looks like ROOT folder has exploded, but I've attached a dump of the files just in case. I've also included all the logs in the log folder. (I ran it the first time from the console using cascade.bat run, and the second time as a windows service.)

    As for the permissions, I don't think that would be an issue, since this is the same machine that we were running a previous instance of Cascade on, and the service is run as a very privileged user.

  4. Support Staff 4 Posted by Tim on 17 Feb, 2012 09:18 PM

    Tim's Avatar

    Can you provide us with the exact steps you took to upgrade/install? The logs are indicative of a bad installation.

  5. 5 Posted by gotankersley on 17 Feb, 2012 09:30 PM

    gotankersley's Avatar

    Sure, here are the steps I took, best as I can remember:
    - First, I downloaded "cascade-6.10.9-win.exe"
    - Then, I stopped the old Cascade instance, and ran the uninstaller to uninstall it. - Then, I created a new test MySQL database, and populated it with http://github.com/hannonhill/Cascade-Server-Default-Database/raw/ma... - Then, I ran the new installer and pretty much went with the defaults. I entered the DB information, and hit test connection, and it said that the connection succeeded. - After that, I configured the Log On user in the Windows service, and tried to run it from there.

    And that's pretty much it, except for trying a couple of different things, like running it from the cascade.bat file. However, I would be willing to try installing it again, just because...

  6. 6 Posted by gotankersley on 17 Feb, 2012 11:26 PM

    gotankersley's Avatar

    Ok, I reinstalled Cascade, and I think I now know what happened: The first time I ran the service, it sat for awhile, and didn't appear to be doing anything, so I killed it. However, this time, I ran it from the console, and it sat on "Deploying the Root.war" for a long time, but I let it do its thing, and it eventually finished.... After that, the install worked fine. Thanks for the help! :-)

  7. gotankersley closed this discussion on 17 Feb, 2012 11:26 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac