ERROR [ContextLoader] : Context initialization failed

espanae's Avatar

espanae

03 Dec, 2013 04:12 PM

Our system administrator has been trying to upgrade our test instance of Cascade from 7.0.5 to 7.8 and consistently gets this error:
2013-12-02 16:47:25,875 ERROR [ContextLoader] : Context initialization failed Attached is the rest of the error. Sometimes the table mentioned in the error is different, but it's always something similar.

Then he gets pages and pages of:
ERROR [MemoryQueueSearchJobScheduler] : An error occurred while consuming from the lucene event queue: java.lang.NullPointerException log4j:ERROR Error occured while converting date. java.lang.NullPointerException

As best he can tell, the second error is a result of the earlier part failing. Now, the foreign key mentioned in the first error (again, see attached) doesn't actually exist in his test database. Apparently none of the foreign keys in production are getting exported to test, but he can't find a way to force them to come along.

He's tried several iterations of upgrades. 7.0.5->7.8, 7.0.5->7.0.7->7.8, 7.0.5->7.0.7->7.6, and even skipping the initial 7.0.5 install and trying to start with 7.6 or 7.8 (the script runs the updater regardless, so installing 7.0.5 is more of a sanity check to make sure the database was imported correctly).

We'd be happy to send along the larger log file if it's helpful, but if you have thoughts for a path to start down in the meantime, that would be great.

Thanks!

  1. Support Staff 1 Posted by Tim on 03 Dec, 2013 06:06 PM

    Tim's Avatar

    Hi,

    Attached is the rest of the error. Sometimes the table mentioned in the error is different, but it's always something similar.

    This makes me think that perhaps not enough time is being allowed for the upgrade process itself to finish. This generally happens when an upgrade is started, it applies a certain number of updates, but then the process is stopped. When the process is started again, it attempts to pick up where it left off, but if it was in the middle of an update when it was stopped, it will attempt to apply that update again (which causes problems).

    I'd like for you all to try the following:

    • Stop the Cascade Server process
    • Restore a copy of your database from prior to any upgrade attempt
    • Start Cascade Server and let it run for 20 minutes
    • If you still can't reach a login screen at this point in time, leave the process running and then attach your most recent cascade.log file here

    At that point I will be able to tell you if the updates are still occurring (which is why you can't login) or if some other error has occurred.

    Thanks!

  2. Support Staff 2 Posted by Tim on 03 Dec, 2013 06:09 PM

    Tim's Avatar

    Also, just a reminder - you can indeed upgrade directly from 7.0.5 to 7.8. At this point, I would actually recommend upgrading directly to 7.8.1 since that is now available.

  3. 3 Posted by espanae on 04 Dec, 2013 07:07 PM

    espanae's Avatar

    Good news: After making some adjustments, the upgrade of our test instance worked (7.8). In a couple of weeks, we'll follow-up with our production server (7.8.1).

    Thanks.

  4. Support Staff 4 Posted by Tim on 04 Dec, 2013 07:16 PM

    Tim's Avatar

    Sounds good! Thanks for the update. Take care!

  5. Tim closed this discussion on 04 Dec, 2013 07:16 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac