JAVA_OPTS for server with 4 GB of RAM

mstevens's Avatar

mstevens

23 Apr, 2013 04:43 PM

Hello!

We recently upgraded to 7.2.2 and things are running smoothly. I just wanted to run our current cascade.sh options by you, specifically JAVA_OPTS to make sure this looks like a sensible setting:

export JAVA_OPTS="-Xmx2048M -Xms2048M -XX:MaxPermSize=192m -Djava.awt.headless=true -Dfile.encoding=UTF-8 -Dnet.sf.ehcache.pool.sizeof.AgentSizeOf.bypass=true"

We had increased our -Xmx value and set the -Xms value based on past discussions, but I remember not being clear if there was an actually advantage bumping it up from 512 (or whatever the default value is). I think we may have been running into some memory leakage in the past and tried this to help an unrelated issue.

In any case, does it look okay to you guys?

Marc

  1. Support Staff 1 Posted by Tim on 23 Apr, 2013 04:52 PM

    Tim's Avatar

    Hi Marc,

    Those settings look just fine to me. As you mentioned, memory modifications usually only need to be made if the application runs out of memory on a consistent basis. An increase in available RAM would also be justified if you happen to perform large publishes during the day when users are working in the system.

    My recommendation would be to keep an eye on the memory usage when end users are working in the system performing normal operations. Under the Administration (dashboard) -> Information tab, you can view the memory usage in real time. If you notice that the free memory is constantly very low (under 300M or so) it may make sense to increase the maximum heap size to something greater (perhaps 2.5G and then maybe 3G). I do not recommend allocating more than about 3/4 of the total system RAM to Cascade.

    Let me know if you have any further questions.

    Thanks!

  2. 2 Posted by mstevens on 23 Apr, 2013 05:03 PM

    mstevens's Avatar

    Great. Thanks, Tim!

  3. mstevens closed this discussion on 23 Apr, 2013 05:03 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac