LDAP sync showing errors

scott.crevier's Avatar

scott.crevier

28 Mar, 2011 04:07 PM

LDAP sync is running automatically twice per hour. In the e-mail I receive, every other one shows this error:

Step 2: Connect to the LDAP server Could not bind to the server to harvest user information using LDAPBind class: class com.hannonhill.cascade.model.security.ldap.bind.LDAPCleartextBind. The error was: [LDAP: error code 32 - NDS error: no such entry (-601)]

The other alternating e-mails show that it was successful. When I run LDAP sync manually, it syncs fine. I'm running Cascade v6.7.6. The 'options' section of my ldap-config is the same as it has been for years. I looked to see if there were any changes required in there, perhaps for recent versions of Cascade, but I don't see anything. I'm looking at this page:

http://www.hannonhill.com/kb/Configuring-LDAP/synchronizing-ldap-us...

I know I can't control the schedule, but I also believe that it's only supposed to run once per hour, not twice. Perhaps the twice per hour schedule is messing things up?

  1. 1 Posted by Joel on 28 Mar, 2011 04:18 PM

    Joel's Avatar

    Scott,

    That's very odd. Could you attach your LDAP XML to this ficket? Also, could you confirm whether or not you are running Cascade Server in a load balanced environment, or if there may be another instance of Cascade running somewhere? Please let me know what you find.

    Thanks!

  2. 2 Posted by scott.crevier on 28 Mar, 2011 07:32 PM

    scott.crevier's Avatar

    Hmmm. I might have a Cascade clone still running that I used to test the upgrade. Good point. I'll check into that yet today.

  3. 3 Posted by Joel on 28 Mar, 2011 08:10 PM

    Joel's Avatar

    Sounds good Scott, please let me know what you find!

  4. 4 Posted by scott.crevier on 29 Mar, 2011 03:01 PM

    scott.crevier's Avatar

    It was the clone. We use this method often, of creating a clone and then banging on that for testing. Part of our standard procedures is to disable all cron jobs when we first start up the clone. Just didn't think about Cascade running its own scheduled stuff.

    I've always wanted to be able to schedule the LDAP sync myself. Doing this in cron would be great.

    Thanks Joel.

  5. 5 Posted by Joel on 29 Mar, 2011 03:26 PM

    Joel's Avatar

    Awesome, glad you found the source of the issue Scott!

  6. Joel closed this discussion on 29 Mar, 2011 03:26 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac