LDAP Sync Issues

Kris's Avatar

Kris

05 May, 2010 02:54 PM

Hope someone can help me out here. I just got Cascade installed and am trying to connect to our LDAP system. The bind works fine and it sees all of the users but for every user it tries to import I get this error in the report:

Import of user from LDAP DN: cn=123456,ou=XXX,ou=XXX,o=XXX failed for the following reason(s):
An error occurred while storing the user information in the database: A domain object failed validation

When I check the log, this is what I see for every user it tries to import:

2010-05-05 09:12:29,755 ERROR [LdapServiceImpl] {User: system, id: not specified, type: not specified} User com.hannonhill.cascade.model.dom.User@a16037[id=123456,name=] did not pass validation.

I have attached my config file (some items changed for security) for your review as well.

Thanks in advance,
Kris

  1. 1 Posted by Joel on 05 May, 2010 03:17 PM

    Joel's Avatar

    Hi Kris,

    After reviewing your LDAP configuration XML, it looks as if you're missing the system-groups and system-roles elements. Please see the example below:

            <system-groups remove-from-other-groups="no">
                        <group>
                            <name>groupName</name>
                            <create-if-does-not-exist>
                                <role>Contributor</role>
                            </create-if-does-not-exist>
                        </group>
                    </system-groups>
                    <system-roles remove-from-other-roles="no">
                        <role>Contributor</role>
                    </system-roles>
    

    This portion needs to go directly after <enable-new-users>yes</enable-new-users> and just before </user-policy>.

    Thanks, and please let me know if this corrects your issue!

  2. 2 Posted by Kris on 05 May, 2010 03:29 PM

    Kris's Avatar

    Oops! I took that out to simplify the file when I was trying to get the binding to work and forgot to put it back in. That fixed it and now my import is working properly.

    Thanks!
    Kris

  3. 3 Posted by Joel on 05 May, 2010 03:42 PM

    Joel's Avatar

    No problem Kris!

  4. Joel closed this discussion on 05 May, 2010 03:42 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac