Use of "[system-asset]" in a CSS file?

clindahl's Avatar


22 Jul, 2010 11:16 PM


I'm having trouble with using the "[system-asset]" pseudo-tag in a CSS file. It doesn't appear to work properly.

Is this a bug?

Specific example:

ul li {

list-style-image: url('[system-asset]/globals/style-3.0/images/bullets/li.png[/system-asset]');
    list-style-position: outside;
    margin-left: 8px;


does NOT work.

ul li {

list-style-image: url('');
    list-style-position: outside;
    margin-left: 8px;


DOES work, although this will then of course depend on the CSS file being present on the server.

How can this be fixed? Or is this construct/pseudo-tag only available in stylesheets or XML blocks?

  1. 1 Posted by Penny on 23 Jul, 2010 11:46 AM

    Penny's Avatar

    On your CSS file, make sure that you go to the System tab and check the "Rewrite links in file" option. This will rewrite all links properly for items within the system-asset tags. This will also cause your links to be tracked so that if someone moves an image your CSS will update the location automatically.

  2. 2 Posted by clindahl on 23 Jul, 2010 03:17 PM

    clindahl's Avatar

    That fixed the problem. Thanks.

    A suggestion: add this note to the section about linking in the "system tags" section at in the Hannonhill Knowledgebase.

  3. 3 Posted by clindahl on 23 Jul, 2010 03:32 PM

    clindahl's Avatar

    A followup to the suggestion above: the link in the Knowledgebase at DOES indeed mention the checking of the "rewrite links" in the System tab.

    Perhaps these pages could be merged somehow in the documentation or at least have references between them?

  4. 4 Posted by Penny on 23 Jul, 2010 03:48 PM

    Penny's Avatar

    I will definitely pass that suggestion along. Thanks!

  5. Tim closed this discussion on 23 Jul, 2010 03:57 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac