Maintain Linux permissions on published files/folders

Alex's Avatar

Alex

20 Jul, 2010 09:23 PM

Hallo,

We use a centralized Cascade server (not managed by us) and we are publishing to our Linux server where we are having permission problems.

The user account we have setup for Cascade to use for FTP does not seem to be properly applying permission to files published to our Linux server. We need all the files and folders to be applied to a specific group with read and write permissions. However Cascade is only publishing with read permissions.

The directory we are publishing to has 2775 (drwxrwsr-x) for the permissions.
The permissions for the files that Cascade publishes are set to 0755 (rwxr-xr-x).

We need these files to be accessible to our Web Team's group but since it's 0755 the group doesn't have write permissions.

Thank you in advance.

  1. 1 Posted by Bradley Wagner on 20 Jul, 2010 09:47 PM

    Bradley Wagner's Avatar

    First, can you tell me if you're using FTP or SFTP to send the files to the Linux server?

    Cascade 6.7, the latest version, respects any umask specified for the user connecting to the remote server when creating files but only when using SFTP Transports. Previous versions had an issue similar to what you're describing where only the user would have write permissions to the file.

  2. 2 Posted by Alex on 21 Jul, 2010 06:52 PM

    Alex's Avatar

    Thank you for the information, Bradley!

    We are using SFTP to send the files to the Linux server.

    I just talked with the people who are managing Cascade for us and we are running version Cascade is 6.4.3. They plan to do an upgrade sometime soon to version 6.7.

  3. 3 Posted by Bradley Wagner on 21 Jul, 2010 06:56 PM

    Bradley Wagner's Avatar

    Great, the best solution will be to upgrade to that version and set a umask for the user connecting to the server that creates the files with the correct permissions. Cascade should respect the umask settings.

  4. Bradley Wagner closed this discussion on 21 Jul, 2010 06:56 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac