'PRIMARY' filegroup is full

T.S.Lindsey's Avatar

T.S.Lindsey

29 Jun, 2010 02:43 PM

6.2 - r12765
A few days ago, during a bulk change operation, I started getting this sort of error:

An error occurred: Hibernate flushing: could not delete: [com.hannonhill.cascade.model.dom.BlobEntity#2c03300b0a01014901c3d30435981ff5]; SQL [delete from cxml_blob where id=?]; Could not allocate space for object 'dbo.cxml_blob' in database 'tempdb' because the 'PRIMARY' filegroup is full. Create disk space by deleting unneeded files, dropping objects in the filegroup, adding additional files to the filegroup, or setting autogrowth on for existing files in the filegroup.; nested exception is java.sql.SQLException: Could not allocate space for object 'dbo.cxml_blob' in database 'tempdb' because the 'PRIMARY' filegroup is full. Create disk space by deleting unneeded files, dropping objects in the filegroup, adding additional files to the filegroup, or setting autogrowth on for existing files in the filegroup.

What is going on, and how can this be fixed?
The sysadmin in charge of the servers tells me there's still 17+GB available.

  1. Support Staff 1 Posted by Tim on 29 Jun, 2010 02:51 PM

    Tim's Avatar

    Hi Lindsey,

    The error you mentioned above is coming from SQL Server. If there is plenty of disk space available on the machine (as your sysadmin claims), then this error is probably the result of a setting that needs to be changed for the database itself. Have your DBA check to see if the data file is set to allow for unrestricted growth. My guess is that your data file has reached the maximum size allowed for your current configuration.

  2. 2 Posted by T.S.Lindsey on 01 Jul, 2010 08:13 PM

    T.S.Lindsey's Avatar

    The problem was the database itself (on a different machine) being completely out of disk space.

  3. T.S.Lindsey closed this discussion on 01 Jul, 2010 08:13 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac