Change in configuration set isn't applying to pages...

lauren.fraser's Avatar

lauren.fraser

04 Mar, 2011 12:40 AM

I have a configuration set that's part of a specific content type. I changed the format for one block in the configuration set and saved it.

Shouldn't this populate to all pages using that content type/configuration set? It's not doing that now. Am I missing a step?

  1. 1 Posted by Charlie Holder on 04 Mar, 2011 01:05 AM

    Charlie Holder's Avatar

    From the description you provided, I can only suggest a few things to check:
    1. Are there Page-level Block assignments? Those assignments would take precedence over assignments made at the Configuration Set level.
    2. Are you changing a Format that applies to a different Configuration? Double-check to make sure you're changing a Format for the specific Configuration out you're looking at.
    3. Are you checking within Cascade or upon publish? Make sure that Configuration is set to publish and that the page you're viewing has been published.

    There are variety of things that could be happening, so it may be difficult for us to help diagnose with the description.

    Hope this helps.

  2. 2 Posted by lauren.fraser on 04 Mar, 2011 03:15 PM

    lauren.fraser's Avatar

    There shouldn't be any page level block assignments. But just in case, is there a way to tell if an assignment is page level vs configuration set level?

    The format changes are on the class-events Configuration in the Default section.

    The classes-events folder has been published since the change, but it's not applying to the pages (except for a few that I did change on the page level).

  3. 3 Posted by Charlie Holder on 07 Mar, 2011 03:51 PM

    Charlie Holder's Avatar

    You can determine the scope for which your Format is applied by looking at the image icon next to the Format assignment. Assignments at the Template level will show our pink Template icon. Assignments at the Configuration Set level will show our blue Configuration Set icon (looks like a book). And assignments at the Page level will show our mostly-white Page icon (looks like a page with a folded top corner).

    If I understand your screen shots correctly:
    The first attachment (class-configuration.gif) is a screen shot of the Configurations Pane of an actual page that you're not seeing any changes reflected on.
    The second attachment (configuration-set.gif) is a screen shot of the specific Configuration Set that is applied to that page.

    I can see that your Configuration Set has a Format called "classes-events" applied to the DEFAULT region at the Configuration Set level (note the blue book icon).

    I can also see that your specific Page has a Format called "classes-events1" applied to the DEFAULT region at the Page level (note the mostly-white page icon).

    The order of precedence for assignments goes: Page -> Configuration Set -> Template. So any assignments on the Page level will override assignments on another level.

    It looks like your "classes-events1" Format (applied on the page itself) is overriding your "classes-events" Format (applied on the Configuration Set).

    You said that you are modifying Formats applied on the Configuration Set level and not seeing changes. I would say that you're not seeing changes to your Format applied at the Configuration Set level because you have a Format applied at the Page level.

    Hope this helps.

  4. 4 Posted by Amy on 07 Mar, 2011 04:15 PM

    Amy's Avatar

    Hi Lauren,

    As Charlie said, assignments made at the Page level (light blue icon) would take precedence over assignments made at the Configuration Set level (dark blue icon), which would take precedence over assignments made at the Template level (pink icon). In general, just remember that a more specific setting will always override a more general setting.

    As for your original question (since I'm not sure if your screenshots were taken before or after you deliberately made page-level changes): If you changed a format assignment at a Configuration Set level and the changes are not reflected within your pages when previewed in the system, then it's possible that you have page-level assignments. If you 'View' one of the pages that isn't showing the changes you applied and see that the DEFAULT region on that page has a light blue icon, then you'll need to remove that page-level assignment in order for it to default back to the Configuration Set assignment. Do the following to remove page-level block or format assignments:

    (1) Click 'Edit > Configurations' on the offending page.
    (2) Click the red 'Minus' icon next to the DEFAULT region's format assignment.
    (3) Click 'Submit' to save your changes.

    If this fixes that page, then you most likely have the same problem on the other pages that are not appropriately displaying your Configuration Set changes and the same steps would need to be applied to those pages one by one. If this does not correct the problem, then let us know and we can suggest a few other items to double check.

  5. 5 Posted by lauren.fraser on 08 Mar, 2011 04:42 PM

    lauren.fraser's Avatar

    Would creating a page from a base-asset make the assignment on the page level?

    I'm just trying to figure out how all the pages in this folder got page level assignments. I created the content type, created the base asset and the asset factory. Then created the pages using that base asset/asset factory.

  6. 6 Posted by Amy on 08 Mar, 2011 04:53 PM

    Amy's Avatar

    Yes, if the base asset has a page level assignment, then all pages created using that base asset would inherit this page level assignment.

  7. 7 Posted by lauren.fraser on 08 Mar, 2011 06:52 PM

    lauren.fraser's Avatar

    Also, when I removed the page level configuration as suggested above, it reverted to the default (_internal/formats/content-center).

    It is using the correct content type.

  8. lauren.fraser closed this discussion on 21 Mar, 2011 08:33 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac