How do I remove a block at the page level?

voltmer1's Avatar

voltmer1

27 Mar, 2015 08:35 PM

I accidentally added a calling page block to my template under the navigation region, so it renders the "default" region page content a second time where the navigation should be. I've deleted it from the template region, but it still shows up on the page itself and the "clear selection" button does nothing. Any suggestions?

  1. 1 Posted by Ryan Griffith on 30 Mar, 2015 12:49 PM

    Ryan Griffith's Avatar

    Hi,

    When you have a moment, try the following steps to clear the Block selection at the page level and let me know how it works out:

    • Edit the Page
    • Go to the Outputs pane
    • Check the No Block checkbox along the right hand side
    • Submit the page

    As an aside, if you are clearing out the selection at the Template level and clicking the unassign button does not clear the assignment, there may be a selection at the Configuration Set level the selection is falling back to.

    Please let me know if you have any questions.

    Thanks!

  2. 2 Posted by voltmer1 on 30 Mar, 2015 01:03 PM

    voltmer1's Avatar

    Thanks Ryan. This changes the double output to the page, but I can still see that the calling page block is in the “NAVIGATION” content block holder on the page. Is there anyway to clear that out rather than just telling the page not to display the navigation block? Why doesn’t the “clear selection” icon work?

    --
    Steve Voltmer | Web Manager
    Communications and Marketing
    ROSE-HULMAN INSTITUTE OF TECHNOLOGY

    5500 Wabash Avenue | Terre Haute, IN 47803-3999
    Phone: 812.877.8644
    [email blocked]<mailto:[email blocked]%0d>
    www.rose-hulman.edu<http://www.rose-hulman.edu/>

  3. 3 Posted by Ryan Griffith on 30 Mar, 2015 01:53 PM

    Ryan Griffith's Avatar

    Not a problem at all, Steve.

    The clear assignment button within the Outputs pane functions a bit differently than what you may be used to for a chooser within a Data Definition. Specifically, clicking this button will cause the assignment to fallback, or default, to an assignment at either the Configuration Set or Template level depending on where the region was configured.

    You indicated the Template level assignment was removed so there is most likely still an assignment at the Configuration Set level. If that is the case, clicking the clear assignment button is causing the chooser to fall back to the Configuration Set assignment. To confirm, if you uncheck the No Block checkbox, you should see a blue icon that looks like a book along the left-hand side of the region's assignment.

    If you wish to remove this assignment across the board for all pages using this Configuration Set, you can simply edit the Configuration Set and clear the assignment. Otherwise, you will need to use the No Block checkbox at the page level to overwrite the assignment.

    Please let me know if you have any questions.

    Thanks!

  4. 4 Posted by voltmer1 on 30 Mar, 2015 02:26 PM

    voltmer1's Avatar

    You were correct it was in the Configuration set. Thanks Ryan!

    --
    Steve Voltmer | Web Manager
    Communications and Marketing
    ROSE-HULMAN INSTITUTE OF TECHNOLOGY

    5500 Wabash Avenue | Terre Haute, IN 47803-3999
    Phone: 812.877.8644
    [email blocked]<mailto:[email blocked]%0d>
    www.rose-hulman.edu<http://www.rose-hulman.edu/>

  5. 5 Posted by Ryan Griffith on 30 Mar, 2015 02:41 PM

    Ryan Griffith's Avatar

    Not a problem at all, Steve. I am glad to hear you were able to track down where the assignment was coming from.

    I'm going to go ahead and close this discussion, please feel free to comment or reply to re-open if you have any additional questions.

    Have a great day!

  6. Ryan Griffith closed this discussion on 30 Mar, 2015 02:41 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac