Tidy HTML

karen.wilson's Avatar

karen.wilson

09 Aug, 2010 08:20 PM

I'm looking for information on what exactly the Tidy HTML feature is supposed to clean up. is an example of what was copied/pasted from MS Word but Tidy HTML didn't do anything about it. This kind of code is showing up as invalid code when running the page through the W3C validator. Am I missing some preference setting that would help me out? Thanks.

Karen

  1. 1 Posted by karen.wilson on 09 Aug, 2010 08:25 PM

    karen.wilson's Avatar

    The pasted code didn't show up in the previous submission.

    span lang="EN-US" link="blue" vlink="blue" xml:lang="EN-US"

    This is the type of code that's not being cleaned up.

  2. Support Staff 2 Posted by Tim on 09 Aug, 2010 08:30 PM

    Tim's Avatar

    Hi Karen,

    We have some information regarding the Tidy HTML preference along with the Remove all font tags and style attributes from word processor content at the bottom of this page.

    Also, can you tell me which version of the software you are using? It may just be a matter of the 'paste from word' functionality not working optimally. This has been greatly improved with the 6.7 release since it comes along with an updated version of TinyMCE.

  3. 3 Posted by karen.wilson on 09 Aug, 2010 08:43 PM

    karen.wilson's Avatar

    We're using version 6.4.5. Thanks for the information.

  4. Support Staff 4 Posted by Tim on 09 Aug, 2010 08:50 PM

    Tim's Avatar

    No problem Karen! If you are unable to resolve the issue by modifying your content preferences, I would recommend upgrading to 6.7.x so that you can see the better 'paste from word' functionality included in the product. My guess is that any tags like these will be removed as expected.

  5. Tim closed this discussion on 09 Aug, 2010 08:50 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac