Horizontal rules disappear on submit

jen9580's Avatar

jen9580

27 Jul, 2010 03:31 PM

I read through this, but the hr tag wasn't mentioned in it:
http://help.hannonhill.com/faqs/rich-text-editor-wysiwyg/content-pr...

The problem we're having is when we insert a horizontal rule, it now disappears on submit. This didn't happen with the prior version. We have our editor set to remove style attributes from tags, but it seems to remove the entire hr tag instead of just the style. Is this expected behavior?

Our old version was 6.2.1, and our current version is 6.4.5.

  1. Support Staff 1 Posted by Tim on 02 Aug, 2010 03:11 PM

    Tim's Avatar

    Hi,

    Do you happen to have exact steps that you can provide me with? I've tried reproducing this locally but haven't been able to yet. So, it may be due to surrounding content or specific keystrokes you are making before or after inserting the <hr/> tag.

    Let me know! Thanks

  2. 2 Posted by jen9580 on 02 Aug, 2010 03:33 PM

    jen9580's Avatar

    Hi Tim,

    Thanks for the response. Here's the exact steps:

    1) Go to edit a page
    2) In main content area, add a horizontal rule using the WYSIWYG editor
    3) Hit submit
    4) Edit page again

    At that point, the hr will be gone. I'm just wondering if this is related to the 'remove all font tags and style attributes from word processor content' setting. I'm betting the horizontal rule stays just fine if you don't have it set to strip style attributes.

  3. Support Staff 3 Posted by Tim on 02 Aug, 2010 03:46 PM

    Tim's Avatar

    Thanks for those steps. I tried this in my local 6.7 instance and found that if I navigated to a page with no content in the DEFAULT region and simply inserted the <hr/> tag, it would stay upon submission of the page. However, if I entered a line of text, inserted the <hr/> tag, then entered another line of text, it got removed. I tried un-checking the Tidy HTML check box and that appears to have been the culprit.

    Can you try this on your end and see if you see the same behavior?

  4. 4 Posted by jen9580 on 02 Aug, 2010 03:55 PM

    jen9580's Avatar

    Yup, just tried unchecking Tidy and it left the hr tag alone. Strangely, subsequent submits with Tidy enabled don't affect the tags. I guess you can just uncheck Tidy the first time to let them sneak by... :)

  5. Support Staff 5 Posted by Tim on 02 Aug, 2010 08:21 PM

    Tim's Avatar

    Good deal. It seems as though TinyMCE (our 3rd party WYSIWYG editor) creates some interesting code when following those steps. Since the code is not valid, Tidy then removes part of it. So, you can either uncheck Tidy as mentioned above (also, there is a global Content Preference to have this unchecked by default) - or - you can try to teach users to use the Cleanup messy code button (looks kind of like a paintbrush). I believe that button will correct the code before Tidy strips it out.

  6. Tim closed this discussion on 02 Aug, 2010 08:21 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac