Why is Cascade eating this code?

turnerjd's Avatar

turnerjd

29 Jul, 2011 01:31 PM

When I put in code in the top of my templates and save it...

<!DOCTYPE html>
<!--[if lt IE 7]> <html class="no-js ie6 oldie" lang="en"> <![endif]-->
<!--[if IE 7]>    <html class="no-js ie7 oldie" lang="en"> <![endif]-->
<!--[if IE 8]>    <html class="no-js ie8 oldie" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js" lang="en"> <!--<![endif]-->

Cascade returns:
<!DOCTYPE html> <html class="no-js" lang="en"> <!--<![endif]-->

I've tried to put it in start end code blocks with no success.

  1. 1 Posted by Lee Roberson (F... on 29 Jul, 2011 03:20 PM

    Lee Roberson (Function Digital LLC)'s Avatar

    If you use the search box you'll find a lot of posts about the HTML5 Boilerplate.

  2. 2 Posted by turnerjd on 29 Jul, 2011 04:05 PM

    turnerjd's Avatar

    Thanks found the solution here. http://help.hannonhill.com/discussions/how-do-i/414-html5-html5boil.... It's the double dashes.

    I was the one that actually posted the orignal doctype hack. https://gist.github.com/422679

    I was hoping they had solved this issue when they rolled out html5 doctype support.

  3. Tim closed this discussion on 29 Sep, 2011 04:49 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac