Feed Block error with https

c-siems's Avatar

c-siems

06 Jul, 2011 08:50 PM

Cascade 6.7.5
When I tried to make a RSS block to a file with https I got this:
An error occurred: Could not parse feed location https://listserv.tamu.edu/cgi-bin/wa?RSS&L=DATA-CENTER-COOLING&...: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

I Googled it and not much available for Cascade. Can Cascade (or Tomcat) pull https RSS files? If you try the URL your browser will give invalid/unknown SSL, but if you push past that, the browser should see the RSS data.

  1. 1 Posted by c-siems on 06 Jul, 2011 09:02 PM

    c-siems's Avatar

    I tried it with non https http://cis.tamu.edu/cis.rss and I got
    An error occurred during editing: null in red at the top

  2. 2 Posted by c-siems on 08 Jul, 2011 09:12 PM

    c-siems's Avatar

    Found this upon further research:
    http://www.java-samples.com/showtutorial.php?tutorialid=210

    Basically, we need to install the keystore so the Sun validator will recognize it. Is that possible in Cascade? Our SSL is probably signed by InCommon.

  3. 3 Posted by Joel on 12 Jul, 2011 03:04 PM

    Joel's Avatar

    Hi,

    Yes, as long as the appropriate certificate is present in your cacerts keystore file, then Cascade should be able to pull this data in. Regarding your non-https issue, I believe you mau be running into a null exception possibly related to something else, or a bad stylesheet within your configuration.

    Thanks!

  4. 4 Posted by c-siems on 13 Jul, 2011 09:53 PM

    c-siems's Avatar

    I don't think it's a https issue per se. It's the retrieval of content wrapped in an unrecognized ssl certificate authority.
    I was able to work around this issue by using a block with a PHP RSS processor. (See block 'sandwich' question on here.)
    Now, the annoying part is since we have a link to the listserv site in the content, the link checker spits out the same error every time we save the content; we just ignore.

  5. 5 Posted by c-siems on 26 Aug, 2011 01:55 PM

    c-siems's Avatar

    After reading about the bug with blocks/formats and workflows, it might be related to that.

  6. 6 Posted by Joel on 26 Aug, 2011 06:10 PM

    Joel's Avatar

    Was your comment above related to this ticket? If so, what bug are you referring to exactly?

    Thanks!

  7. 7 Posted by c-siems on 26 Aug, 2011 08:30 PM

    c-siems's Avatar
  8. 8 Posted by Joel on 07 Oct, 2011 02:29 PM

    Joel's Avatar

    Regarding the non-https attempt you may be right in that it's related to the proposed issue you've mentioned. As for https I don't think it is related to that issue, as the error states that it is "unable to find valid certification path to requested target", which leads me to believe it's related to SSL, specifically the inability to accept a certificate. Whatever user is running Cascade Server on the application side needs to have access to this certificate or the ability to store it.

    Did Tim's comment here solve your issue when using non-https? Please let me know.

    Thanks!

  9. 9 Posted by c-siems on 07 Oct, 2011 04:37 PM

    c-siems's Avatar

    I'm not sure Tim's comment applies. We don't use workflows. It might if he's talking about RSS blocks - but he also said it will be fixed in later versions.
    Like I said, our work around was to use a PHP RSS/XML parser.

  10. 10 Posted by Joel on 07 Oct, 2011 05:01 PM

    Joel's Avatar

    Good deal, glad you found a resolution!

  11. Joel closed this discussion on 07 Oct, 2011 05:01 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac