Optimize Database - Internal Server Error

Ronnie Passaro's Avatar

Ronnie Passaro

18 Mar, 2016 05:47 PM

I tried the Optimize Database option in the System Menu and after about a minute I received an Internal Server Error. I'm sure why this happened or what to do about it.

Thanks,
Ronnie

  1. Support Staff 1 Posted by Tim on 18 Mar, 2016 06:16 PM

    Tim's Avatar

    Hi Ronnie,

    Which particular option in the Optimize Database screen did you select to run (or did you select all of them)? It's possible they are still running in the background, but I can verify once I know which specific options you selected.

    As far as the internal server error is concerned, it sounds like you're hitting a timeout. Are you using something like Apache by any chance in front of Cascade or are you just running Cascade standalone (via Tomcat)?

  2. 2 Posted by Ronnie Passaro on 18 Mar, 2016 06:22 PM

    Ronnie Passaro's Avatar

    I selected all of them. I'll find out if we are using Apache or Tomcat.

    -Ronnie

  3. 3 Posted by Ronnie Passaro on 21 Mar, 2016 05:00 PM

    Ronnie Passaro's Avatar

    We have Apache in front and are using ajp_proxy to Tomcat.

  4. Support Staff 4 Posted by Tim on 21 Mar, 2016 05:15 PM

    Tim's Avatar

    Gotcha. So, in that case, the internal server error is because the Apache Timeout setting was reached. You could try increasing it to something like 2 or 3 minutes, but to be honest, running all of those optimization tasks at the same time could potentially take upwards of 30 minutes. It really all depends on the size of your database. Is there a particular reason you were running the DB optimizer? For example, were you looking to try to shrink the database size a bit?

  5. 5 Posted by Ronnie Passaro on 21 Mar, 2016 05:17 PM

    Ronnie Passaro's Avatar

    Thanks for the help. We wanted to see if it cleaned up the database and reduced its size.

  6. Support Staff 6 Posted by Tim on 21 Mar, 2016 05:22 PM

    Tim's Avatar

    Gotcha. In that case, I would recommend taking a look at the following Content Preferences in your instance:

    • Global Max Upload (KB)
    • Max Asset Versions

    These both have a direct effect on database size. Since files are stored in the database, you'll probably want to limit the max upload to something reasonable (maybe under 10MB?). Then, I would recommend checking to see that your Max Asset Versions setting is something finite - maybe around 15 or 20. The reason for this is that if someone uploads a 10MB file, for example, and that file is edited 10 times over the course of a few years, it ends up using approximately 100MB of storage on the database server (10 versions x 10MB).

    If you do consider lowering the Max Asset Versions setting, this article describes how that process works after the change has been made.

    Let me know if you need anything else.

    Thanks

  7. Tim closed this discussion on 29 Mar, 2016 02:13 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac