HTML5 in WYSIWYG - TinyMCE

Lisa McWilliams 's Avatar

Lisa McWilliams

15 Sep, 2015 03:13 PM

From Todd at Samford

How do I keep the editor from reformatting my code? This is a major issue because most of our 700 calls to action are designed to take advantage of HTML 5’s code structure to ensure that mobile devices have a large target area based on standards compliant code instead of javascript and css hacks.

This issue is with the editor, because the untouched content from migrating the content blocks is fine. The problem occurs, whenever the content is loaded in the editor. It seems to re-format code for XHTML, which doesn’t allow block level elements inside A tags.

Here are my settings:
My template DOCTYPE is correctly set for HTML5
HTML Tidy is turned off
TinyMCE supports HTML5 validation through a schema setting as well as valid_elements, exetended_valid_elements, and invalid_elements settings. Based on what I see in the wysiwyg.js, invalid_elements isn’t set and both valid_elements, and extended_valid_elements are set to [] which should allow all elements.

  1. 1 Posted by Penny on 15 Sep, 2015 09:47 PM

    Penny's Avatar

    The following resource fixed the issue. http://stackoverflow.com/questions/14597219/how-to-configure-tinymc...

    So I am closing out this ticket.

  2. Penny closed this discussion on 15 Sep, 2015 09:47 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac