Hibernation error

crcampbel's Avatar

crcampbel

02 Jan, 2015 05:11 PM

We implemented the latest version of Cascade on a development instance of our CMS a week before leaving for the holidays. The dev instance was working before we left (I was able to log in), but on our return today an error has been preventing us from logging in. Attached is the error we're receiving.

Our IT department confirmed that there is sufficient disk space on both the application and database servers. Also, the database is already set to unrestricted growth.

Other theories are that it is a permissions problem between the dev instance and the DB since the DB was copied from prod, or a problem with the analytics connector. I started the verification process of the analytics connector right before heading out on break. I thought it was working fine a that point, but never attempted to log in again after doing so.

Any idea what could be causing this and how we can resolve it?

Thanks,
Craig

  1. 1 Posted by Bradley Wagner on 02 Jan, 2015 05:13 PM

    Bradley Wagner's Avatar

    Can you please send us your latest system logs which will contain more details on that error message?

    Thanks!

  2. 2 Posted by crcampbel on 02 Jan, 2015 05:46 PM

    crcampbel's Avatar

    Hi Bradley,

    I don’t know when the issue started to occur. You requested the latest system logs. Would the latest one be OK? I apologize for being so picky, but I will need to note in my email to the network administrator the log file date or date range you will want to look at.

    Thanks,
    Craig

  3. 3 Posted by Bradley Wagner on 02 Jan, 2015 05:48 PM

    Bradley Wagner's Avatar

    If you're still seeing the error, then we should be able to see it in the latest logs. Are you a CMS admin? If so, you can access/download the logs directly. We'd want the cascade.log and catalina.out to start with.

  4. 4 Posted by crcampbel on 02 Jan, 2015 06:01 PM

    crcampbel's Avatar

    Hi Bradley,

    I am a CMS administrator. How would I be able to access the logs without logging in? The error on the login page prevents me from logging in.

    Craig

  5. 5 Posted by Bradley Wagner on 02 Jan, 2015 06:03 PM

    Bradley Wagner's Avatar

    Ah, I see. Sorry about that. Yes, you'll want to ask your admin to zip up the Cascade/tomcat/logs directory which will contain everything and send that along. It should compress down a lot.

    Thanks!

  6. 6 Posted by crcampbel on 02 Jan, 2015 06:04 PM

    crcampbel's Avatar

    OK. I just figured it out. I was able to log in. Attached is the log file you requested.

    I’m using a piz extension. This is to get our firewall. It is really a zip document. Just change the extension and it should work.

  7. 7 Posted by Bradley Wagner on 02 Jan, 2015 06:10 PM

    Bradley Wagner's Avatar

    Thanks Craig. Does the problem appear to be intermittent at this point since you were able to log in to get this file?

    I'm seeing a lot of errors connecting to the database. For example,

    Caused by: java.sql.SQLException: I/O Error: Connection reset
        at net.sourceforge.jtds.jdbc.TdsCore.executeSQL(TdsCore.java:1053)
        at net.sourceforge.jtds.jdbc.TdsCore.submitSQL(TdsCore.java:899)
        at net.sourceforge.jtds.jdbc.ConnectionJDBC2.setAutoCommit(ConnectionJDBC2.java:2248)
        at org.apache.tomcat.dbcp.dbcp.DelegatingConnection.setAutoCommit(DelegatingConnection.java:371)
        at org.apache.tomcat.dbcp.dbcp.PoolingDataSource$PoolGuardConnectionWrapper.setAutoCommit(PoolingDataSource.java:328)
        at org.hibernate.transaction.JDBCTransaction.begin(JDBCTransaction.java:63)
    

    Unfortunately, the errors in the log aren't very specific about what the connection problem is.

    Has anything changed with your MSSQL database of late? Could you try restarting the Cascade instance to see if the problem persists?

  8. 8 Posted by crcampbel on 02 Jan, 2015 06:27 PM

    crcampbel's Avatar

    I was able to log in, because the hibernation error provided a link to “Home”. I had ignore this link when initially scanning the error.

    I’m not sure about the other errors. The CMS appears to be working OK for the most part. I have noticed that it does seem a little slow, the Google Analytics connector isn’t updating (stuck on December 12) or in many instances showing no data, and got a 500 error when navigating to the Stale Content page. Below is a screen grab of the error. Let me know if you can’t see it. There could be more issues, but I think we have plenty to focus on at the moment.

    [cid:[email blocked]]

    I’d have to check with ITS about any MSSQL changes, but I don’t think there have been any.

    If I request a restart would you need me to send you a new log file? How long would I need to wait before doing so. I’d assume you would want me to wait a little bit for the data to populate in the log file.

    Thanks,

    Craig

  9. 9 Posted by Bradley Wagner on 02 Jan, 2015 07:02 PM

    Bradley Wagner's Avatar

    That last error indicates that the system is out of memory which would definitely contribute to the slowness. Let's try restarting the system and giving it a few hours to run and then collecting the logs again if the problem persists.

    Thanks for you help in gathering this information.

  10. 10 Posted by crcampbel on 02 Jan, 2015 07:23 PM

    crcampbel's Avatar

    OK. I will submit the request. I’ll let you know when it is complete, and get you a log file. This may not get to you late today or Monday.

    Craig

  11. Support Staff 11 Posted by Tim on 27 Jan, 2015 07:57 PM

    Tim's Avatar

    Hi Craig,

    Just wanted to follow up on this post to see if you all still need help. Let us know if you are still running into problems and we'll be happy to take a look at log files from the day(s) when this last occurred.

    Thanks!

  12. 12 Posted by crcampbel on 28 Jan, 2015 02:22 PM

    crcampbel's Avatar

    Hi Tim,

    We are all set with this ticket for now.

    Craig

  13. Support Staff 13 Posted by Tim on 28 Jan, 2015 02:24 PM

    Tim's Avatar

    OK, glad to hear it, Craig. I appreciate the update!

  14. Tim closed this discussion on 28 Jan, 2015 02:24 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac