Workflow starts and advancements not showing up in audits

samsone's Avatar

samsone

04 Feb, 2014 04:11 PM

I have assets that I know have workflows attached to them and are in various stages. However, when I run an audit they are not showing up at all and I'm not sure why.

Any ideas?

Thanks!

  1. 1 Posted by Bradley Wagner on 04 Feb, 2014 04:20 PM

    Bradley Wagner's Avatar

    Hi, can you tell us which asset, user, group, or role you're using to using to view the Audits? Generally if I wanted to see this data, I would go to the user, group, or role that I thought was responsible and check the audits of that object. See the attached example for some recent workflow activity for my user.

  2. 2 Posted by samsone on 04 Feb, 2014 04:27 PM

    samsone's Avatar

    I am trying to look at a page and see if a workflow had been started or advanced on it. I know there are workflows in progress, but they aren't showing up.

  3. 3 Posted by Bradley Wagner on 04 Feb, 2014 05:05 PM

    Bradley Wagner's Avatar

    The Audits tab for a page should show the workflow activity for any completed workflows.

    If the asset has a working copy and is still in an active workflow, try clicking the "working copy" and then going to the Audits for the Working Copy.

    Let us know if that shows you the workflow activity for the workflow currently in progress.

  4. 4 Posted by samsone on 04 Feb, 2014 08:14 PM

    samsone's Avatar

    No, it's not - is there perhaps a server configuration that needs to be looked into?

    Thanks for responding so quickly!

  5. 5 Posted by Bradley Wagner on 04 Feb, 2014 09:26 PM

    Bradley Wagner's Avatar

    Is the information visible on the Audits for the User object for the user that you believe was involved in the Workflow? That will help us determine if the data was capture and is just not visible or if it was not captured at all.

  6. 6 Posted by samsone on 04 Feb, 2014 09:45 PM

    samsone's Avatar

    Yes, I can see the information on the user.

  7. 7 Posted by Bradley Wagner on 04 Feb, 2014 09:47 PM

    Bradley Wagner's Avatar

    Ok, and when your user goes to the asset in question and clicks the Working Copy and then Audits, you're not seeing anything at all?

    Could you include a screenshot of both your user's audits as well as the audits for the working copy of the asset that they're making changes to?

  8. 8 Posted by samsone on 05 Feb, 2014 01:51 PM

    samsone's Avatar

    It looks worse than I thought - when I did an audit on the asset, it only shows operations performed in January, but if I audit the user, it shows operations performed in Feb with workflows. All of the operations on the asset aren't even showing. I'm trying to use web services to generate a report on each asset to show if there is a workflow on it, but if it's not showing up on the cascade server, I'm not going to get the information with web services either. I've attached screenshots.

  9. 9 Posted by Bradley Wagner on 05 Feb, 2014 04:25 PM

    Bradley Wagner's Avatar

    Thanks.

    When you go to the asset itself, is it still in workflow? Or have those workflows completed?

    If they're still active, can you please: switch to the "working copy" using the link in the View tab, open the Audits for the working copy, and then take a screenshot of the Audits for the working copy if there are any?

  10. 10 Posted by samsone on 05 Feb, 2014 06:24 PM

    samsone's Avatar

    Here is a screenshot of the working copy audit.

  11. 11 Posted by samsone on 18 Feb, 2014 03:12 PM

    samsone's Avatar

    Just checking in to see if there was an answer to resolve this issue. Thanks!

  12. Support Staff 12 Posted by Tim on 18 Feb, 2014 03:27 PM

    Tim's Avatar

    Hi there,

    Sorry for the delay! So far we haven't been able to reproduce this behavior in a local instance. What version of the software are you currently using?

    Also, we'll probably need some more specifics regarding your problem. Can you tell us which particular audits are showing up in once place but not the other?

    Thanks

  13. 13 Posted by samsone on 18 Feb, 2014 03:42 PM

    samsone's Avatar

    We just upgraded to 7.8. I am trying to generate a report of workflows that are still in progress on assets - when I go to the assets and perform the audits, no workflow information is available, but I know that there are workflows in progress on them. The only way I can see any workflow progress currently is by auditing users. I hope that makes sense....

  14. Support Staff 14 Posted by Tim on 18 Feb, 2014 03:56 PM

    Tim's Avatar

    It does make sense.

    when I go to the assets and perform the audits, no workflow information is available

    When you're doing this, are you navigating to the Working Copy of the asset prior to viewing the audits or are you viewing the audits on the original copy? I can see that you had attached a screen shot of the Working Copy audits at one point here. Can you tell me which audits are showing up in the User audits for this asset but not showing up in the Working Copy audits for the asset?

  15. 15 Posted by samsone on 18 Feb, 2014 04:15 PM

    samsone's Avatar

    The workflow advancements and starts are showing when I audit users, the workflow starts and advances are not showing on assets. Other than that, I believe that all other audit items are displaying.

  16. Support Staff 16 Posted by Tim on 18 Feb, 2014 04:21 PM

    Tim's Avatar

    Thanks for that information. I'll do some further testing over here to see if I can confirm and I will get back to you once I've had a chance to do so. I appreciate your patience!

  17. Support Staff 17 Posted by Tim on 26 Feb, 2014 07:09 PM

    Tim's Avatar

    After looking at this further along with my developers we have identified some issues with the behavior. I've logged 2 items in our project which you can track here:

    https://hannonhill.jira.com/browse/CSI-732
    https://hannonhill.jira.com/browse/CSI-733

    Thanks for your patience while we worked through this. Keep an eye on release notes for any new versions that become available so that you can see whether or not these 2 items made it in. Apologies for the inconvenience!

    Let me know if you have any further questions at this time.

  18. Tim closed this discussion on 21 Mar, 2014 08:46 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac