.docx File

rpatel's Avatar

rpatel

16 Oct, 2013 07:04 PM

Hi,

I'm able to open a word document with .docx extension in Cascade but not on the live site. It gives 401 error message.

Thank you,
Rakesh

  1. Support Staff 1 Posted by Tim on 16 Oct, 2013 07:17 PM

    Tim's Avatar

    Hi Rakesh,

    401 errors on your web server generally mean that the area you are accessing requires some sort of authentication. Check out this page and let me know if the steps there help you to track this down.

    Thanks

  2. 2 Posted by rpatel on 18 Oct, 2013 04:16 PM

    rpatel's Avatar

    Hi Tim,

    My mistake. The error is 404 (page cannot be found). I have attached screen shots. the error page stays for a second and than redirects to Yahoo error page. If I change the file name from .docx to .doc (System name) it works.

    Thank you,
    Rakesh

  3. 3 Posted by Jason Aller on 18 Oct, 2013 09:44 PM

    Jason Aller's Avatar

    The file is there as a .doc file, I was able to download it.

    When .docx files are uploaded they should have .docx as the the end of their system names.

    Good file names would not have spaces; replace spaces with dashes.

  4. 4 Posted by rpatel on 23 Oct, 2013 02:03 PM

    rpatel's Avatar

    Actually i changed it to .doc (from .docx) to see if it works. I have re-uploaded the file with dashes instead of spaces, like you suggested, but I'm still getting an error. Please go to this link (http://soka-test.soka.edu/administration/finance-and-administration/information-technology/Test1/default.aspx) and see if you can download the file.

  5. Support Staff 5 Posted by Tim on 23 Oct, 2013 03:30 PM

    Tim's Avatar

    Hi Rakesh,

    A few questions for you:

    • Can you confirm that the .docx file has been published from your Cascade Server instance?
    • If it has been published, can you attach the publish message for that asset here?
    • Is the file showing up in the file system on the web server in the location specified by the URL? (If you don't have credentials to log in to the web server directly, you may need to ask your web server admin to check for you)
  6. 6 Posted by Jason Aller on 23 Oct, 2013 03:37 PM

    Jason Aller's Avatar

    I'm wondering at the server behavior difference between 404ing some times and trying to send an incomplete 404 page other times. Which web server are you running and does it have a mime type configuration for .docx?

  7. 7 Posted by rpatel on 23 Oct, 2013 06:07 PM

    rpatel's Avatar

    Hi Tim & Jason,

    Thank you for looking into this. The file is published. I have attached screen shots of publish message and web server file system. I also checked the MIME setting and added .docx (screen shot attached) but still getting error.

  8. Support Staff 8 Posted by Tim on 23 Oct, 2013 06:19 PM

    Tim's Avatar

    Rakesh,

    Thanks for attaching that information. Everything looks good from the Cascade Server side of things since the file is physically on your web server. So, I'm with Jason now thinking this may still be some sort of MIME type issue.

    Was that MIME type added recently? If so, have you restarted IIS so that those changes actually take effect? Also, I can only see part of the actual MIME type in the screen shot. Can you confirm that it looks something like this:

    application/vnd.openxmlformats-officedocument.wordprocessingml.document
    
  9. 9 Posted by rpatel on 24 Oct, 2013 02:11 PM

    rpatel's Avatar

    MIME type wasn't there before. I added it per Jason's suggestion and it's working now. Looks like i had to wait for the change to take effect. Thank you so much for the support.

  10. Support Staff 10 Posted by Tim on 24 Oct, 2013 02:15 PM

    Tim's Avatar

    Cool, thanks for the update! Have a good one.

  11. Tim closed this discussion on 24 Oct, 2013 02:15 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac