block and format on the page level being turned off and on

ssuh's Avatar

ssuh

06 Oct, 2010 05:21 PM

Hi, we have a template that has a block and xsl formatting based off a data definition. On one of our pages the XSL is disabled since we assigned an XHTML block.

One of our users went in and just made an update to the wyswig and after he submitted his changes, the XSL was somehow enabled. I was checking to see if there is anything that would cuase this. The user said he did not touch the configurations.

  1. Support Staff 1 Posted by Tim on 07 Oct, 2010 04:29 PM

    Tim's Avatar

    Hi Steve,

    As far as I know, the only way this happens is if a user un-checks the 'No Format' checkbox (after it had previously been checked). Doing so will cause the Format which was previously assigned to that region to be applied once again.

  2. Support Staff 2 Posted by Tim on 11 Oct, 2010 06:51 PM

    Tim's Avatar

    Steve,

    I have an update for you. I just had someone else report this same exact behavior and they were able to provide me with steps to reproduce it on my own. For more information on the problem, check out the issue I created for it here. Please let your user know that this is a bug which will be addressed in a future patch release.

    Apologies for the inconvenience!

  3. Tim closed this discussion on 11 Oct, 2010 06:51 PM.

  4. ssuh re-opened this discussion on 13 Oct, 2010 05:19 PM

  5. 3 Posted by ssuh on 13 Oct, 2010 05:19 PM

    ssuh's Avatar

    Thanks Tim.

    It happened to one of our users but we don't use content types. I'm still trying to figure out the exact steps he took.

    Steve

    -----Original Message-----
    From: Tim [mailto:[email blocked]]
    Sent: Monday, October 11, 2010 3:01 PM
    To: Suh, Stephen J.
    Subject: [BULK] Re: block and format on the page level being turned off and on [General]
    Importance: Low

  6. Support Staff 4 Posted by Tim on 13 Oct, 2010 06:38 PM

    Tim's Avatar

    Hi Steve,

    This could still be the same issue. While the steps I provided to reproduce the problem mention using a content type, it isn't essential to the problem itself. Instead, it's just a way to tie a Configuration Set to a Page. It sounds like you are editing some older assets that were created before Content Types were available. So, instead of having a Content Type associated with a page (which ties together a Configuration and Metadata Set with an optional Data Definition) your Configuration Set and Metadata Set are associated with the page assets separately.

    The main things to check will be:

    • Does the user have the Modify Page Configurations on pages ability disabled for their Role?
    • Has the No Block or No Format box been checked for a region that is overriding a Template- or Configuration Set-level assignment?

    Assuming the answer to both questions is 'yes', this is likely the problem you are running into. Let me know what you find.

  7. 5 Posted by ssuh on 28 Oct, 2010 06:14 PM

    ssuh's Avatar

    Going back to this issue -

    http://issues.hannonhill.com/browse/CSI-60

    I was able to duplicate it with the following:

    1. In configurations under the page level, under a region - Turn XSLT formatting off.
    2. Go back and add text to the region that uses the XHTML.
    3. Submit changes. Then view the config level and see the xslt -formatting block has reverted back to the template level.

    Steve

    -----Original Message-----
    From: Suh, Stephen J.
    Sent: Wednesday, October 13, 2010 1:19 PM
    To: 'Tim'
    Subject: RE: [BULK] Re: block and format on the page level being turned off and on [General]

    Thanks Tim.

    It happened to one of our users but we don't use content types. I'm still trying to figure out the exact steps he took.

    Steve

    -----Original Message-----
    From: Tim [mailto:[email blocked]]
    Sent: Monday, October 11, 2010 3:01 PM
    To: Suh, Stephen J.
    Subject: [BULK] Re: block and format on the page level being turned off and on [General]
    Importance: Low

  8. Support Staff 6 Posted by Tim on 28 Oct, 2010 06:31 PM

    Tim's Avatar

    Sounds good Steve. As of now, the issue is tentatively scheduled to be addressed in our next patch release (6.7.4). Be sure to keep an eye on the release notes for this issue when the patch becomes available.

    Thanks

  9. Tim closed this discussion on 28 Oct, 2010 06:31 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac