Added content node in data definition

c-siems's Avatar

c-siems

14 Feb, 2013 10:29 PM

Not sure if this is a bug or a feature.
I'm getting empty <content /> elements mixed into data definition elements when that element has content.
Here is the data definition. Standard image/file selector with wysiwyg editor.

<system-data-structure>
  <group identifier="FacultyStaff" label="Faculty Staff" multiple="true">
    <asset type="file" identifier="photo" label="Photo"/>
    <text wysiwyg="true" identifier="contact_info" label="Contact Info" required="true"/>
  </group>
</system-data-structure>

When the photo is filled I get

<FacultyStaff>
  <photo>
    <content />
    <path>/images/someimage.jpg</path>
    <dynamic-metadata>
      <name>ShowInSiteNavigation</name>
      <value>Yes</value>
    </dynamic-metadata>
    <link>site://mysite/images/someimage.jpg</link>
    <site>mysite</site>
    <name>someimage.jpg</name>
  </photo>
  <contact_info>
    <p>
    ...
    </p>
  </contact_info>
</FacultyStaff>

When the photo is left blank I get

<FacultyStaff>
  <photo>
    <path>/</path>
  </photo>
  <contact_info>
    <p>
    ...
    </p>
  </contact_info>
</FacultyStaff>

Is the <content /> supposed to be there?

  1. Support Staff 1 Posted by Tim on 21 Feb, 2013 01:58 PM

    Tim's Avatar

    Hi there,

    We always render the <content /> tag inside of Data Definition asset chooser renderings when there is an asset selected. Symlink and File contents are not allowed (and so that tag will appear as empty). Page and Block contents will be displayed if the render-content-depth setting is configured to be higher than the current depth.

    Let me know if you have any further questions.

    Thanks

  2. c-siems closed this discussion on 03 Apr, 2013 04:37 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac