html characters in text field from data definition

judy's Avatar

judy

08 Jul, 2013 03:20 PM

I know that to get special html characters (e.g. é) to display in the Title filed, you use the html code é. This also works in text fields defined in the data definition as long as you define it as wysiwyg="true". If you don't add wysiwyg="true", the é is automatically translated to the character once the page or block using the data definition has been saved. That would be fine except when I publish the page, it's not the correct character. I'm assuming it's because it's no longer the html code.

Adding the wysiwyg="true" isn't an awful solution but it does allow for more editing than I would like users to have(even trimming it down as much as the data definition builder allows). It also makes the field a lot larger and makes the 'form' I've created more cumbersome to use.

Is there any way other than adding the wysiwyg feature to stop the automatic conversion from taking place? Since it doesn't happen in the Title field, I'm hoping it's just something obvious that I've overlooked.

  1. 1 Posted by Ryan Griffith on 08 Jul, 2013 05:49 PM

    Ryan Griffith's Avatar

    Hi Judy,

    I was trying a few things out in my local Cascade 7.4 instance and noticed the entity é was automatically converted when entered in both a Data Definition and the Title fields. What version of Cascade are you experiencing this behavior in?

    Off-hand, one option could be to use Xalan and Javascript to perform a String replace to essentially re-encode the entity. I posted a Format containing similar logic to this discussion.

    Please let me know if you have any questions.

    Thanks!

  2. 2 Posted by Ryan Griffith on 17 Jul, 2013 07:03 PM

    Ryan Griffith's Avatar

    Hi Judy,

    Just wanted to follow up to see if you had a chance to view my recent comment. Were you able to come up with an alternative solution?

    Please let us know if you have any questions.

    Thanks.

  3. Ryan Griffith closed this discussion on 26 Jul, 2013 12:58 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac