Narrow down the advanced search by site?

Joel Trauger's Avatar

Joel Trauger

20 Jan, 2016 03:58 PM

I was reading the Knowledge Base and ran across this:

"Normally search terms are applied to all searchable fields for an Asset. Search terms can be limited to a given field by prefixing it with the field name. For example, the query " and name:test*" would find all assets whose names started with test for the Site"

So I tried entering site:www name:polic* to find all the pages pertaining to policies on the Site www but it just returned a huge red error stating that it could not parse the search.

What am I doing wrong?

  1. Support Staff 1 Posted by Tim on 20 Jan, 2016 04:44 PM

    Tim's Avatar

    Hi Joel,

    Thanks for the report. I just tried this on a local instance and while I'm not receiving an error, I'm also not getting back the results I would expect. I'll need to do some digging to see if that is due to a bug or bad documentation (I don't recall being able to scope a search by Site, but I could be wrong).

    In the meantime, can you replicate the error you are seeing and then immediately attach your cascade.log file?

  2. 2 Posted by Joel Trauger on 21 Jan, 2016 08:48 PM

    Joel Trauger's Avatar

    We are running on 7.10, which is currently unsupported. Do you want me to try to update before doing this? I'd hate to report a bug that has already been fixed in a current version.

  3. Support Staff 3 Posted by Tim on 21 Jan, 2016 08:52 PM

    Tim's Avatar

    Hey Joel, thanks for the info. I looked over our changelog and didn't see anything specific to search that has been corrected since then, so feel free to just attach your log file from the day you ran into that error. Once I have a look at it, I'll be able to quickly determine whether or not it's something that may have been corrected in a newer release.


  4. 4 Posted by Joel Trauger on 21 Jan, 2016 09:04 PM

    Joel Trauger's Avatar

    The log shows nothing except a PDF I need to go correct the name on before it causes bigger problems. I attached a screenshot of the search inputs and the outcome.

    I'm thinking it's bad documentation at this point because entering the same input on the simple search gives exactly what I wanted. The Advanced Search however failed completely.

    Maybe I'll suggest a rework of the advanced search on the Idea Exchange after version 8 hits the shelves...


    Looking at my screenshot, apparently Windows 10 makes the * look a little funny but I assure you I input it and not the " that appears on my screen.

  5. Support Staff 5 Posted by Tim on 21 Jan, 2016 10:09 PM

    Tim's Avatar

    Thanks for that info, Joel! OK, this is on me because when I tested I was just using the Basic Search (I should have tried the Advanced Search). I believe those two operations actually use different searching methods which would explain why you are only seeing that message when you use Advanced Search.

    I searched our issue tracker and was able to find the related bug. I've linked it to this issue, so I can let you know once we have a fix ready for it.

    I apologize for the inconvenience! Let me know if you need anything else at the moment.


  6. Ryan Griffith closed this discussion on 05 Feb, 2016 04:15 PM.

  7. Support Staff 6 Posted by Tim on 08 Feb, 2016 06:19 PM

    Tim's Avatar

    Hey Joel,

    Just wanted to let you know we've resolved the issue I mentioned earlier in this ticket and I expect that fix to go into a release in the near future. You'll be able to see mention of it in the Release Notes when that item is included in a release.


  8. Tim closed this discussion on 08 Feb, 2016 06:19 PM.

Discussions are closed to public comments.
If you need help with Cascade CMS please start a new discussion.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac


26 Aug, 2016 01:19 PM
25 Aug, 2016 03:02 PM
25 Aug, 2016 12:50 PM
24 Aug, 2016 08:43 PM
24 Aug, 2016 07:20 PM
21 Aug, 2016 01:20 PM